seoseo
tr-opencart

     
avatar Şuanki Zaman: 05-24-2017, 05:23 AMHoşgeldin Misafir !
  Şifremi Hatırlat   kayıt ol
opencart temaları

Opencart 1.4.x ten 1.5.x e güncelleme betiği

Konuyu görüntüleyenler: 1 Misafir
 
Değerlendir:
  • 0 Oy - 0 Yüzde
  • 1
  • 2
  • 3
  • 4
  • 5
%
Cevapla  Gönder 
v  v
Yazar  sabitertan - Görüntüleme - Okunma  9114 - Yorum  27

osdem66v
Forum Kurucusu
*******
Administrators user avatar
Çevrimdışı

Mesajlar: 1,817
Konular: 129
Katılma Tarihi: Dec 2011
Rep Puanı: 24
Teşekkürler: 366
462 Mesajına, 1229 Teşekkür edildi.



Kişisel Bilgileri: v
Konu Tarihi: 09-02-2013 10:40 AM
(Bu Mesaj 09-02-2013 10:44 AM değiştirilmiştir. Değiştiren : osdem66.)
Güncelleme Adımları
DİKKAT! BU GÜNCELLEME YAZILIMINI ÇOK FAZLA SEÇENEĞİ OLAN MAĞAZALARDA KULLANMANIZ ÖNERİLMEZ. ÇÜNKÜ SEÇENEKLERİ AKTARMAMAKTADIR GÜNCELLEME SONUCU ÜRÜNLERE EKLEDİĞİNİZ SEÇENEKLERİ KAYBEDERSİNİZ. BUNU GÖZE ALARAK UYGULAMAK SİZE KALMIŞTIR. BİR KAÇ SEÇENEĞİ BULUNAN SİTELER SONRADAN EKLEYEBİLİRLER. BU KOMUT DOSYASI VAROLAN VERİTABANINIZDAKİ KATEGORİLERİ, ÜRÜNLERİ, MÜŞTERİLERİ, SİPARİŞLERİ VB. VERİLERİNİZİ KORUR. SEÇENEK EKLİ SİPARİŞLERİNİZDE SİPARİŞ DETAYINDA SEÇENEK GÖRÜNMEYECEKTİR ANCAK SİPARİŞ TOPLAMI KORUNACAKTIR.

Başlamadan Önce Yapılması Gerekenler


Güncelleme sonunda default tema seçilecektir ancak başlamadan önce mağaza ayarlarınızdan seçmeniz önerilir
Kurduğunuz modülleri, ödeme ve kargo methodlarını, sipariş toplamları gibi buna benzer sonradan eklediğiniz özellikleri yönetim panelinden kaldırmanız önerilir.
OpenCart'ın sistem dosyalarından yapılan değişikler güncelleme sonrası dosyaların üzerine yazılacağı için hata oluşturmayacaktır.

GÜNCELLEMEYE BAŞLAMADAN ÖNCE KESİNLİKLE TÜM DOSYALARINIZIN VE VERİTABANIZIN YEDEĞİNİ ALINIZ

OpenCart 14x den 15 versiyona güncelleme betiğini konudaki ilk mesajdan indiriniz.
Bu dosyaları bilgisayarınızda bir yere çıkarınız
İndirdiğiniz güncelleme betiği dosyası içinde bulunan dosyalarının sitenizin ana dizinine (opencart'ın kurulu olduğu dizine )yükleyiniz. Karşınıza çıkan üzerine yazılsın mı sorusuna evet deyiniz.
Ana dizindeki config.php dosyasına aşağıdaki kodu ekleyiniz. (admin/config.php dosyası değil.)
(sunucunuzdaki config.php ve admin/config.php dosyalarının CHMOD izinlerini 444 yaptıysanız geçici olarak 755 ya da 777 yapınız).

Kuruluma başlamadan önce system/cache/ içindeki index.html hariç tüm dosyaları silin.
Yükleme bittikten sonra 'http://www.siteadresiniz.xxx/install/upgrade-14x-to-15x.no-opt.php' adresini tarayıcınızın adres çubuğuna yazarak çağırınız.
Eğer "SUCCESSFUL" yazısı ile karşılaştıysanız bir sonraki adıma geçebilirsiniz. Eğer hata ile karşılaştıysanız bunu forumdaki konu altında bildiriniz.
"SUCCESSFUL" mesajından sonra yönetim panelinde oturum açın ve Sistem->Kullanıcılar->Kullanıcı Grupları (System->Users->User Groups da bulunan Yönetici (TOP ADMINISTRATORS) grubunu düzenleyerek tüm kutucukları işaretleyin ve kaydediniz.
Sistem->Genel Ayarlar (System->Settings) mağaza ayarlarınızı kontrol ederek güncelleyiniz.
Tarayıcınızın ön belleğini temizleyiniz.
Ana sayfanızı ziyaret ediniz. Ana sayfada ürün ya da modülü görünmeyecektir. Bu bir hata değildir telaş yapmayınız. Modül ayarlarından ana sayfayı seçerek gösterebilirsiniz.
Ve mutlu son. . . Smile

Ana dizindeki config.php içine Eklenmesi Gereken Kod

ana dizinde bulunan config.php dosyasında bulun // DIR Öncesine ekleyin(Eğer daha önceden ekli değilse) SSL kullanıyorsanız HTTPS bölümündeki adreslerin başını https olarak değiştirin.


// HTTP

define('HTTP_SERVER', 'http://www.siteadersiniz.xxx/');

define('HTTP_IMAGE', 'http://www.siteadersiniz.xxx/image/');

define('HTTP_ADMIN', 'http://www.siteadersiniz.xxx/admin/');

// HTTPS

define('HTTPS_SERVER', 'http://www.siteadersiniz.xxx/');

define('HTTPS_IMAGE', 'http://www.siteadersiniz.xxx/image/');

Anlatım:eka7a
osdem66
Alıntı Yaparak Cevapla
Paylaş!
opencart temaları
osdem66v
Forum Kurucusu
*******
Administrators user avatar
Çevrimdışı

Mesajlar: 1,817
Konular: 129
Katılma Tarihi: Dec 2011
Rep Puanı: 24
Teşekkürler: 366
462 Mesajına, 1229 Teşekkür edildi.



Kişisel Bilgileri: v
Konu Tarihi: 09-02-2013 10:54 AM
(09-01-2013 11:39 PM)AVON.SF Yazılan:  Merhabalar. Sitemi, yani sub domain de açtığım deneme sürümünü 1.5.1.3 ten 1.5.5.1 'e yükseltmeyi başardım. Ancak bunu yaparken bazı noktaları da kendim öğrendim ( En az 15 kere sub domainde 1.5.1.3 kurdum da Smile ) Bunları da sizinle paylaşmak istedim.

1. si eski sürümlerden yedek almadan önce tüm modülleri kapatın yada kaldırın. Sonra da mysql dosyasını indirip saklayın.
2. si Hostunuzdan da full yedek alın.
3. sü ustaların bana anlattığı gibi adımları takip edin.
4. sü ise çok takıldığım bir nokta oldu ki siteadı.com/install olmalıymış. Ben hep siteadı.com/install.php yapmışım. Buna çok dikkat etmek gerek
5. si ve en önemlisi. Beni çok uğraştırdı çünkü. osdemm ustanın webposlu 1.5.5.1 surumu güncelleme için her kullandığımda sorun yaşadım. Hata kodları da o yüzdenmiş. Eski sürümde olmayan 2 modul, Gelişmiş slayt gösterici ve Özel Tab modulu ile galiba pos dosyaları güncellemeyi bozuyor. Normal 1.5.5.1 sürümünü indirip kurduğumda güncelleme sorunum kalmadı.

Bunu özellikle paylaşmak istedim. Benim gibi başkaları da günlerce uğraşmasın diye. Osdemm usta da bu webposlu sürümünü tekrar gözden geçirir belki. Direk kurulumda sorunsuz çalışıyor. Ama güncelleme de hatalı. Umarım bir kaç gün sonra gerçek sitemi de sorunsuz güncellerim. Sorun olursa da yardım alacağım yer belli. Smile Yine de teşekkürler.
Merhaba; webpos lu sürüm standart sürüm Sabit Ertan tarafından üzerine çeşitli modifikasyon ve eklentilerle güclendirilmiş bir sürümdür..bu sürümün neyini güncelliyorsunuz zaten son sürüm bu; 1551 ve bir güncelleme betiği degildir eğer bu sürümü kullanarak alt sürümleri güncellemeye çalışıyorsanız zaten hatayı başta yapıyorsunuz..
Ve ayrıca bir yanlışlığı da düzeltelim alt sürümlerden 1551 e güncellemek için herhangi bir upgrade dosyası yayınlanmamıştır yani bir güncelleme betiği yoktur..bunu yapabilmek için opencartın tüm sürümlerine ve özellikle 1551 sürümüne ait dosyalara ve veritabanı tablolarına çok iyi hakim olmak gerekir çünki bir çok işlemi manuel olarak yapmak orundasınız..selametle..
osdem66
Alıntı Yaparak Cevapla
Paylaş!
 Teşekkür Edenler: AVON.SF
AVON.SFv
Acemi Üye
**
Üye user avatar
Çevrimdışı

Mesajlar: 18
Konular: 0
Katılma Tarihi: Jul 2012
Rep Puanı: 0
Teşekkürler: 5
1 Mesajına, 1 Teşekkür edildi.



Kişisel Bilgileri: v
Konu Tarihi: 09-02-2013 12:59 PM
Webposlu 1551 sürümünü sizin çalışmanız olarak biliyordum osdem66 usta. Yanlışlık için kusuruma bakmayın. Zaten bu konularda acemiyim. Üye statümden de belli Smile Ben 1513 ten direkt olarak webposlu sisteme yükseltmeye çalıştım. Nasıl olsa en son şekli diye. Bunu da öğrenmiş oldum. Ama benim gibi acemiler için bir bilgi notu yazmış oldum tecrübelerimi yazarak. Herkesin emeğine saygımız sonsuz. Tekrar sağolun.
Alıntı Yaparak Cevapla
Paylaş!
ismail-ayv
ismail-ay
***
Üye user avatar
Çevrimdışı

Mesajlar: 93
Konular: 12
Katılma Tarihi: Nov 2012
Rep Puanı: 0
Teşekkürler: 11
5 Mesajına, 6 Teşekkür edildi.



Kişisel Bilgileri: v
Konu Tarihi: 11-26-2015 03:28 PM
1.5.x den 2.0 versiyona güncelleme betiğide çıksa KEŞKE Smile
Alıntı Yaparak Cevapla
Paylaş!
emrealtunv
EmreAltun
**
Üye user avatar
Çevrimdışı

Mesajlar: 5
Konular: 2
Katılma Tarihi: Nov 2015
Rep Puanı: 0
Teşekkürler: 4
0 Mesajına, 0 Teşekkür edildi.



Kişisel Bilgileri: v
Konu Tarihi: 11-30-2015 01:04 PM
Merhaba arkadaşlar burdakileri okudum baktım tek tek sırayla denedim ama hata aldım. bir sitemi 1.4.7 vardı 1.4.9 yaptım. 1.4.9 da kategorilerim çalışmıyordu ama site düzgün açılıyordu. Sonra opencart 1.5.1.2 dosyasını indirdim install dosyasına burdaki dosyayı atım site açılmadı snra "http://www.siteadresiniz.xxx/install/upgrade-14x-to-15x.no-opt.php"şeklinde yaptım SUCCESSFUL yazdı sonra css bozuk şekilde geldi adminde Sistem->Kullanıcılar->Kullanıcı Gruplarından hepsini seçtim sonra tema değişimi yapim dedi hata verdi "Uyarı: Oluşan hatalar için lütfen formu dikkatli kontrol ediniz!" modül kısmına girmek istediğim de de "Error: Could not load language module/html_block!" hatası alıyorum. Bu güncellemeyi nasıl yapabilirim bu css e diğer hataları nasıl düzeltebilirim acaba ?
Alıntı Yaparak Cevapla
Paylaş!
dumansoftv
Acemi Üye
**
Üye user avatar
Çevrimdışı

Mesajlar: 1
Konular: 0
Katılma Tarihi: Dec 2015
Rep Puanı: 0
Teşekkürler: 0
0 Mesajına, 0 Teşekkür edildi.



Kişisel Bilgileri: v
Konu Tarihi: 01-08-2016 02:39 PM
arkadaşlar 1.4.x olan opencart sitemizi 1.5.1.3 sürümüne güncelleme betiği ile güncelledim bütün ayarlarını yaptım site sorunsuz çalışıyor fakat ürün detay sayfalarında beyaz sayfa alıyorum yani boş çıkıyor oysaki bilgi sayfaları ve diğer sayfalar çalışıyor nedeni ne olabilir?
Alıntı Yaparak Cevapla
Paylaş!
opencart temaları
Bensawv
Acemi Üye
**
Üye user avatar
Çevrimdışı

Mesajlar: 7
Konular: 2
Katılma Tarihi: Jul 2015
Rep Puanı: 0
Teşekkürler: 0
0 Mesajına, 0 Teşekkür edildi.



Kişisel Bilgileri: v
Konu Tarihi: 04-25-2016 11:44 AM
2.1 den 2.2 ye güncelleme yi yapabilecek arkadaşlar var mı acaba.
Alıntı Yaparak Cevapla
Paylaş!
willymanv
Acemi Üye
**
Üye user avatar
Çevrimdışı

Mesajlar: 1
Konular: 0
Katılma Tarihi: Aug 2013
Rep Puanı: 0
Teşekkürler: 0
0 Mesajına, 0 Teşekkür edildi.



Kişisel Bilgileri: v
Konu Tarihi: 05-24-2016 11:57 PM
(01-08-2016 02:39 PM)dumansoft Yazılan:  arkadaşlar 1.4.x olan opencart sitemizi 1.5.1.3 sürümüne güncelleme betiği ile güncelledim bütün ayarlarını yaptım site sorunsuz çalışıyor fakat ürün detay sayfalarında beyaz sayfa alıyorum yani boş çıkıyor oysaki bilgi sayfaları ve diğer sayfalar çalışıyor nedeni ne olabilir?

Aynı sorunu bende yaşamaktayım neden olabilir yardımcı olabilirmisiniz
Alıntı Yaparak Cevapla
Paylaş!

« Önceki | Sonraki »
Cevapla  Gönder 

Opencart 1.4.x ten 1.5.x e güncelleme betiği Konusunun Linki Direk Link
Opencart 1.4.x ten 1.5.x e güncelleme betiği Konusunun HTML Kodu HTML Link
Opencart 1.4.x ten 1.5.x e güncelleme betiği Konusu BBCode Linki BBCode Link
Opencart 1.4.x ten 1.5.x e güncelleme betiği Konusunu Paylaş Sosyal Paylaş

Benzeyen Konular
Konu: Yazar Cevaplar: Gösterim: Son Mesaj
  [Mod] Opencart 2.3.0.2 Ödeme modülü ekleme bysrcn93 0 146 04-21-2017 01:24 PM
Son Mesaj: bysrcn93
  Opencart yüklediğim tema panelde gözükmüyor seymanuryilmaz 4 532 03-12-2017 02:03 PM
Son Mesaj: yilmaz70
  ÜCRETLİ GÜNCELLEME izmirdavetiye 0 113 02-21-2017 03:12 PM
Son Mesaj: izmirdavetiye
Question 2.2.0.0 sürümünden 2.3.0.2 Sürümüne güncelleme ridwanxelil 2 174 02-14-2017 10:20 AM
Son Mesaj: ridwanxelil
  Opencart 2.3.0.2 Kurulum Saçmalığı ecagriyildirim 5 591 02-10-2017 01:08 PM
Son Mesaj: yilmaz70
Information Opencart 2.1.0.1 KDV Oranlarının ayarlanması sualci 2 1,853 02-01-2017 11:48 AM
Son Mesaj: muratasan97
  Opencart 1.5.6 dan Opencart 2 nasıl geçilir. sanalx 16 3,898 01-24-2017 10:41 PM
Son Mesaj: ahmeteren
  Opencart 1.5.2.x versiyonunu bulamıyorum sometimestaner 1 107 01-24-2017 07:04 PM
Son Mesaj: osdem66
  2.0.3.1 den 2.1.0.1 güncelleme sualci 1 777 11-27-2015 12:48 PM
Son Mesaj: sualci
  opencart sürümümü 1.5.6 dan 2.0.3.1 e yükseltmek istiyorum bunu nasıl yapabilirim? xhumen 1 836 09-26-2015 03:12 AM
Son Mesaj: tigrap

Opencart 1.4.x ten 1.5.x e güncelleme betiği indir, Opencart 1.4.x ten 1.5.x e güncelleme betiği Videosu, Opencart 1.4.x ten 1.5.x e güncelleme betiği online izle, Opencart 1.4.x ten 1.5.x e güncelleme betiği Bedava indir, Opencart 1.4.x ten 1.5.x e güncelleme betiği Yükle, Opencart 1.4.x ten 1.5.x e güncelleme betiği Hakkında, Opencart 1.4.x ten 1.5.x e güncelleme betiği nedir, Opencart 1.4.x ten 1.5.x e güncelleme betiği Free indir, Opencart 1.4.x ten 1.5.x e güncelleme betiği oyunu, Opencart 1.4.x ten 1.5.x e güncelleme betiği download


Forum Atla: